This project has moved and is read-only. For the latest updates, please go here.

System cannot find the file specified

Sep 4, 2011 at 10:30 AM
Edited Sep 4, 2011 at 11:31 AM

====================== UPLOAD LOG ======================

- Setup variables: Completed

- Database creation: Error: The system cannot find the file specified

- Database creation verification: Error: The system cannot find the file specified

- Database security configuration: Error: The system cannot find the file specifiedUpload failed!

I've hard coded all the paths that I've found in case that's the issue, but's still not working, which is a shame...

Any ideas?


ETA: I took the raw SQL from the files and ran them in order (edited of course) in a DB I manually created. This did get me up and running, but I guess the deployment app needs looking into.

Sep 4, 2011 at 4:00 PM

Hi Keni,

It sounds like if the Wizard can't find the files or does not have permissions to access them. One common issue (with this and other downloaded files) is that Windows is blocking the file (and also when you decompress it, magically also blocks the uncompressed files). Can you check if the files are blocked?

Sep 14, 2011 at 11:07 PM


I have the same problem.

The zip file was blocked.

After unblocking the zip and uncompress the files again, I still have the same problem. 

Can it be a firewall issue?
What port should I open?


Sep 15, 2011 at 11:59 AM

Hi cutechimp,

this is not a firewall related issue. The wizard at this point is only trying to open local files on the wizard subfolders. Please, check that after uncompressing the ZIP files, the unzipped contents are not blocked in the same manner that the ZIP file was blocked (when you uncompress a blocked ZIP file, the uncompresed files are also blocked).

Tell me if this fix the problem.



Sep 15, 2011 at 9:32 PM

Hi David,

the files are not blocked or read-only.



Sep 18, 2011 at 7:06 PM

In order to know more about the issue, please tell me:

  • Full path from where you are running the wizard
  • Are you a local machine admin?
  • Have you tried with "Run as an administrator"?
  • Antivirus programs? Have you tried to disabling them?






Dec 30, 2011 at 10:39 PM
Edited Dec 30, 2011 at 10:40 PM

The error is caused by the fact the command line action requires 'sqlcmd.exe' needs to be registered on your computer!   You can see this command by looking at the 'DeploymentTask.xml' file, located in the config folder.  For Tasks 1-3, you see the XML shows <commandline>sqlcmd.exe</commandline>.

To resolve this error, simply install the SQL Express installation onto your computer.  You can test if this worked successfully by going to the command prompt and typing 'sqlcmd /?' to see if you get an error.  If you get help instructions, then the command will work.


Jan 2, 2012 at 9:36 AM

That makes sense. I'll include the sqlcmd.exe command line tool and dependencies in the next release. Thanks @berben11 for the info.



Jan 2, 2012 at 9:37 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Jan 17, 2012 at 8:21 AM

Thank you, @berben11.

This helped me :-)

I had to uninstall all my SQL and Visual Studio versions on my computer. Restarted several times.
Installed SQL Express from this link: 

Then tested 'sqlcmd /?' from command prompt and it worked :-)

Then when I ran DotNetNuke Azure Accelerator Wizard (6.1 RTM) it all worked fine :-)



Stian - CuteChimp