This project has moved and is read-only. For the latest updates, please go here.

This site is currently unavailable!

Oct 1, 2011 at 10:40 AM
I installed DNN 6 using he Azure accelerator wizard approx 7 days ago. All was running fine and I was conducting functionality tests. Yesterday, my cloud app URL returned the above message. The reason why eludes me. I presume the SQL azure database cannot be found! The first mystery is why? What changed. I have not made any configuration changes since initial installation and it was working fine. I have looked at the DatabaseConnection string value. Added that account as a SQL Azure login. Changed the connection to my SQL Azure admin account credentials to see if the string is the issue! All to no avail. Any pointer on how to remedy this issue would be appreciated. I know I can just start over but I need to get to grips with Azure so I would rather know cause and effect than just fix without knowing what is happening. Am I missing something? Definitely going to get o grips with RDP. In the interim, what's my issue?
Oct 1, 2011 at 1:36 PM

Hi cube, the first thought was that you were referring to "Service unavailable", which means the the IIS application pool suffered a shutdown for consecutive errors (RDP is very useful to start again the the application pool without the need of restarting the webrole). 

But after a search, I believe that you are referring the DNN message "This site is currently unavailable". I suppose that you have googled this error, and found this link and tried to reconfigure the web.config through the Install wizard. If you can't pass from the SQL configuration step, the only thing that I can imagine at this moment (thinking on an SQL Azure issue and not a DNN issue), is that "MicrosoftServices" is not added to the SQL Azure firewall rules. Perhaps have you missed that rule? If not, try to delete and recreating it. See the "Allow other Windows Azure services to access this server" checkbox on the SQL Azure firewall rules.

Other things to try:

  • Open MSSMS (SQL Server Management Studio 2008 R2 SP1, you can use the express edition) and connect to your SQL Azure, and run this query in order to see if is not a SQL related problem: "select top 100 * from EventLog order by logcreatedate desc"
  • Redeploy: delete production service and deploy again with the same service package and service configuration files

Send me feedback to know if this solves something.



Oct 2, 2011 at 8:13 PM

Hi David

Thanks for the prompt reply. I have the site running again. I changed the database connection string to my admin account and stopped and started the host service. Voila! Still not sure why it occurred in the firs palce. So I have at least been back on testing. All has gone well there so far. Still anxious to find my way around the cloud and get equally as comfortable with azure as traditionally file system. So, now I have DNN running again I want to get RDP working. I have followed your guide: The new issue - when I right click and publish to "Configure Remote Desktop Connections" I get a dialog box "Publish Windows Azure Settings" not "Deploy Windows Azure Project" as is documented in your guide! So when I get want to click OK at step 10), after coniguration the RDP window, I have a disabled publish button! Checked I'm using 1.4 Tools. Do you know why the difference. I feel RDP will give me more insight and visualisation.

Overview help? Reading the .vhd page blob. The cerebrata tool sounds very useful. Is there a way to map the .vhd file system locally? Then drag and drop (wishful?). Can same be achieved once I have RDP working anyway? Looking forward to getting comfortable with the Azure process!

Thanks for your help

Oct 7, 2011 at 1:53 PM

Hi cube, I don't know if you saw my last post about configuring RDP without Visual Studio that I wrote last sunday (see, and click on the "Translate" button, sorry for the inconvenience). I mention a "manual" procedure to change the RDP credentials and finally I show a new step on the DNN Azure Wizard that is available for the next release. 

The only thing is that following the post instructions, you only need the "additional" RDP compiled package. I'll recompile the ".cspkg" with RDP enabled and publish for download for you -and the people that may want it- in a temporary URL until the next release of the Wizard (I want to introduce a few other features before the launch). 

I'll update this thread with the URLs in a few moments.