This project has moved and is read-only. For the latest updates, please go here.

403 with DNNAzureSingleExtraSmall

Aug 14, 2011 at 8:35 AM

I'm using the ExtraSmall version (DNNAzureSingleExtraSmall.cspkg) of the accelerator and is also facing the 403 error when trying to access my deployment. Similar to http://dnnazureaccelerator.codeplex.com/discussions/268159.

In order to uderstand what is going I would like to enable Remote Desktop and have read the guide by davidjrh, which describes how to modify and build the DNNAzureSMB project.

Does anyone know which project which is used to build the DNNAzureSingleExtraSmall.cspkg?

There is a project called DNNAzureSingle, but no "DNNAzureSingleExtraSmall". I tried to upgrade my deployment created by the acceleerator wizard, with a package built from DNNAzureSingle but it does not have the same number of endpoints.

 

Aug 15, 2011 at 12:33 PM

Hi @Skogis,

The DNNAzureSingleExtraSmall package was built with the DNNAzureSingle project (selecting "ExtraSmall" size for the instances on the settings page). You need to rebuild the package in order to deploy it with the RDP settings, because the Azure deployment process checks the type and number of settings that were included when it was built.

This 403 error is worring me, so I'll take a deep look today to discover what are the possible issues.

Thanks for feedback.

Aug 15, 2011 at 1:15 PM

Thanks, I'll try to set the correct setting, rebuild and deploy again, but the 403 will probably be still there. I'm a newbie when it comes to Azure/Windows 2008 Server and web development, so I'm not sure what to do once I have RDP :) I'm just playing around and testing stuff to get some experience. So, for me it is not urgent to get it working, but I saw other people having a similar problem.

Aug 15, 2011 at 1:26 PM
Edited Aug 15, 2011 at 2:16 PM

Hi again,

could you check the "log" subfolder and the log files inside? I've detected that if you choose a bad password for the SQL runtime user, the wizard does not detect the error and does not warn that on the error window, for example:

Creating Login:  test403
CREATE LOGIN test403 WITH PASSWORD = '1111';

Msg 40630, Level 16, State 1, Server va3wqctdkf, Procedure sp_create_login, Line 1
Password validation failed. The password does not meet policy requirements because it is too short.

I've also check that the SMB package (DNNAzureSMB6.0.cspkg) included on the complete DNN Azure wizard had an incorrect entry definition (package). I'll include the fixed package after resolving the 403 error.

Aug 15, 2011 at 1:35 PM
Edited Aug 15, 2011 at 1:39 PM

Another reason should be that you are using the same VHD on another deployed service. Please, check the setting <Setting name="driveName" value="dotnetnuke.vhd" /> and make sure that you aren't using the same VHD on another deployed service. If you want to create more DNN deployed services, you should choose different VHD names for each one (i.e. dotnetnuke6.vhd, mydrivename.vhd, etc.). This entry is not modified during the uploading process, so you need to change it manually. I'll include this setting on the wizard in a future release.

Aug 15, 2011 at 5:01 PM
Edited Aug 15, 2011 at 5:01 PM

After two successful deployments, I've built a list about the main reasons of the 403 error. Check the "Documentation" page to see the list and tell me if one of them fix your problem. (http://dnnazureaccelerator.codeplex.com/documentation)

Thanks for feedback